Ability to wipe an application's User data on Android Enterprise
Summary
Issue
SOTI MobiControl Administrators are unable to wipe an application's User data on Android devices enrolled with an Android Enterprise agent.
Affects
All devices enrolled with an Android Enterprise agent below version 13.6.0 Build 1662.
Cause
The issue occurs because there currently is no standard Google API to wipe an application's User data for the Android Enterprise offering.
Related SOTI ONE Platform Products
Process Description
Issue
SOTI MobiControl Administrators are unable to wipe an application's User data on Android devices enrolled with an Android Enterprise agent.
Affects
All devices enrolled with an Android Enterprise agent below version 13.6.0 Build 1662.
Cause
The issue occurs because there currently is no standard Google API to wipe an application's User data for the Android Enterprise offering.
Resolution
Please upgrade your Android Enterprise agent* to version 13.6.0 Build 1662 or above, and send the script below to wipe an application's User data. On Samsung devices, a Samsung ELM License must be activated for the script command to work. For devices other than Samsung devices, an Android Enterprise Plugin version 1.13 or above (https://docs.soti.net/mobicontrolagentdownloads) must also be installed on the devices for the script command to work.
To wipe an application's User data, send the following script:
wipeapplication <packageID>
Was this helpful?
Thanks for your feedback