Android Enterprise MGPA Enrollment Issue with MobiControl 15.1.0
Summary
Issue
Enrollment Fails with an account creation error when attempting to enroll more than 10 devices using Managed Google Play Accounts (MGPA).
Affects
This issue affects customers running SOTI MobiControl 15.1.0.3413 which was released on March 23, 2020.
Cause
MobiControl 15.1.0.3413
Related SOTI ONE Platform Products
Process Description
Issue
Enrollment Fails with an account creation error when attempting to enroll more than 10 devices using Managed Google Play Accounts (MGPA).
Affects
This issue affects customers running SOTI MobiControl 15.1.0.3413 which was released on March 23, 2020.
Cause
MobiControl 15.1.0.3413 erroneously provisions the same Managed Google Play Account for all devices enrolled with the same MGPA Enterprise binding. There is a limit of 10 devices for each MGPA and this is why the 11th attempted device enrollment fails.
Resolution
Upgrade MobiControl to version 15.1.0.3416 or higher.
Once MobiControl has been upgraded, the following actions need to be taken to correct the Managed Google Play Accounts of the devices which were previously enrolled into MobiControl 15.1.0.3413:
1. Find the devices that you enrolled into MobiControl 15.1.0.3413. Use the device search function and query below to get the complete list of affected devices:

2. Select all applicable devices and then use the "Reset Account" device action.

3. If there are multiple Android Enterprise bindings, select only the binding originally used to enroll the device in the drop down option then select "Reset Account."
To confirm that the devices have a unique account, click the device and check the Android Identity details under Device Details:

Contact SOTI Support if you have any additional questions about this procedure.
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