Managed Google Play apps are uninstalling from devices, or failing to install onto devices, after registration code update

Publish Date: 27-Mar-2019 Android
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Summary

Issue

Managed Google Play apps are uninstalling from devices, or failing to install onto devices, after the SOTI MobiControl registration code has been updated. 

Affects

All production licensed SOTI MobiControl instances prior to version 13.3.0.3766 (13.3 Maintenance Release 10) that are distributing applications via Managed Google Play where the MobiControl registration code was updated. New registration codes are typically iss

Related SOTI ONE Platform Products

Android

Process Description

Issue

Managed Google Play apps are uninstalling from devices, or failing to install onto devices, after the SOTI MobiControl registration code has been updated. 

Affects

All production licensed SOTI MobiControl instances prior to version 13.3.0.3766 (13.3 Maintenance Release 10) that are distributing applications via Managed Google Play where the MobiControl registration code was updated. New registration codes are typically issued on license renewals or when license counts are modified.

Cause

When Managed Google Play applications are added to an App Catalog rule, SOTI MobiControl sends this information to SOTI’s cloud services which in turn configures Managed Google Play with the applications and the device/accounts that have access to them. To establish this association between the Managed Google Play applications, devices/accounts and the SOTI MobiControl instance, SOTI’s cloud services use the MobiControl registration code. Prior to SOTI MobiControl 13.3.0.3766, SOTI’s cloud services did not receive updates of the registration code, which broke this association and resulted in devices:

  1. not installing Managed Google Play apps, and
  2. removing previously installed Managed Google Play apps.

In some cases, but not always, the device user also saw a Pending Action prompt from the MobiControl agent that persisted on the device.

Resolution

Customers affected by this issue should contact SOTI Support immediately and provide their updated registration code. SOTI will update the registration code in SOTI’s cloud services. Once the update has taken place, devices will resume installation of Managed Google Play applications and re-install any applications that were erroneously removed. SOTI Support can be reached at Support@Soti.net or at 1-888-624-9828.

Moving forward, affected customers are encouraged to upgrade to SOTI MobiControl 13.3.0.3766 or greater, or contact SOTI Support immediately after they have updated their SOTI MobiControl registration code.

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