Users are not be able to log in to SOTI Identity using their IdP credentials
Summary
Issue
Users are not able to log in using their IdP credentials after the new release of SOTI Identity (v1.1 released on 6th June 2020).
Affects
This issue affects customers who have integrated IdP with SOTI Identity prior to 6th June.
Cause
In this new release, SOTI Identity has brought support for IdP initiated login. It means that after integration of SOTI Identity with an IdP, users&n
Related SOTI ONE Platform Products
Process Description
Issue
Users are not able to log in using their IdP credentials after the new release of SOTI Identity (v1.1 released on 6th June 2020).
Affects
This issue affects customers who have integrated IdP with SOTI Identity prior to 6th June.
Cause
In this new release, SOTI Identity has brought support for IdP initiated login. It means that after integration of SOTI Identity with an IdP, users can log into SOTI Identity directly from their IdP portal. They don’t need to re-authenticate.
To bring this support SOTI Identity has changed its Entity ID to make it tenant specific. Earlier, SOTI Identity ‘s entity ID was common for all customers. Due to this change existing integrations which have used generic Entity ID will start failing.
Resolution
The existing customers who have integrated SOTI Identity with a 3rd party IdP (ADFS, Azure AD, Okta, Onelogin, etc.) would be required to change SOTI Identity’s entity ID in their IdP Admin console.
How to find the new Entity ID of SOTI Identity?
- Go to SOTI Identity admin console -> Directory/IdP -> Select IdP connection -> click Edit Action
- You will be shown Downloads button
- Download Identity Metadata
- Open Metadata file and search for Entity Id of SOTI Identity (see below image for reference)
After finding the Entity ID, you need to go to the 3rd party IdP's Admin portal (e.g. ADFS, Azure AD, etc.) and edit SOTI Identity's configuration by replacing SOTI Identity's Entity ID with new value.
Was this helpful?
Thanks for your feedback