Microsoft Entra Shared Device Registration Failure on Android Blocking Enrollment and SSO
Summary
Related SOTI ONE Platform Products
Related Device OS
Issue Description
An issue impacted the Microsoft Entra ID Shared Device Registration workflow for customers using Shared Device Mode on Android devices, beginning February 25.
During enrollment, some devices were unable to retrieve the required Device Registration Token from Microsoft Intune. This resulted in enrollment failures and related disruptions, including:
-
Incomplete device identity creation
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Compliance partner binding failures
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Single Sign-On (SSO) authentication issues
Microsoft resolved the issue on February 28, and Shared Device Mode enrollment has since returned to normal operation.
Environment
The issue impacted all deployed versions of SOTI MobiControl managing Android devices configured for Shared Device Mode.
Symptoms
Users enrolling Android devices in Shared Device Mode were encountering either timeouts or error messages when retrieving the Device Registration Token. Microsoft Authenticator, which is acting as a broker fails to perform the Shared Device Mode registration with the following HTTP 500 InternalServerError and exception shown in logs:
[2026-02-25 12:46:38.882] DBG [General] (81): PartnerApi.HttpClient: HTTP Response: StatusCode: 500, ReasonPhrase:
'Internal Server Error', Version: 1.1,
Response body: {"error":{"code":"InternalServerError","message":"An internal server error has occurred.","target":"","details":[],"innererror":{} }
[2026-02-25 12:46:38.882] ERR [General] (81):
******************************************************************************************************
* Exception: AzureSharedDeviceRegistrationWorkflow: Fail to proceed with shared device registration. *Prevention
A fix was developed and deployed by Microsoft on February 28. The Shared Device Registration workflow has resumed normal operation.
No changes or updates to SOTI MobiControl are required.
Cause
During enrollment, when SOTI MobiControl fails with the HTPP 500 InternalServerError, the workflow fails at:
RetrieveAndroidDeviceRegistrationToken()
AzureSharedDeviceRegistrationWorkflow – Fail to proceed with shared device registration
Issue Resolution
Our teams worked closely with Microsoft to investigate and remediate the issue.
Microsoft identified a recent service change that may have contributed to the failure in the Shared Device Registration workflow and implemented corrective measures. The fix was validated in Microsoft’s pre-production environment before being safely rolled out to all customers.
Full deployment of the resolution was completed on February 28.
Workarounds
At this time, the recommended action is to retry enrollment using Shared Device Mode on affected Android devices, as the fix has been fully deployed by Microsoft.
No additional configuration changes are required.
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