Apps Removed from Devices and Cannot Be Deployed

Publish Date: Last Modified Date: SOTI MobiControl
708

Summary

This article provides steps to troubleshoot apps that are greyed out. Apps were automatically removed from devices without SOTI MobiControl intervention.

Related SOTI ONE Platform Products

SOTI MobiControl

Related Device OS

Android Classic;Android Enterprise;iOS

Issue Description

Apps are sometimes automatically removed/uninstalled from devices without apparent reason. In the SOTI MobiControl web console, the impacted apps are greyed out under App Policies, and you cannot access any configurations related to those apps or push them down to devices.

Environment

SOTI ONE Platform: SOTI MobiControl

Device OS: Android Classic, Android Enterprise, and iOS

Symptoms

  • Apps are uninstalled from devices without any apparent reason.
  • On the device side, the app is no longer installed.
  • Symptoms are similar to those mentioned in the SOTI MobiControl help guide. Devices are in the process of getting unenrolled, or the AE binding is unbound.

Disclaimer from the online help.

Prevention

There are no preventive measures for this issue. If a developer withdraws their apps from the iOS App Store or Managed Google Play Store, little can be done. You may need to contact the developers to obtain the IPA/APK file.

Cause

The developers of the app may have found a bug in a new release or changed the pricing model from free to paid, leading to the withdrawal of the app. Developers may not disclose the reasons for these actions.

Issue Resolution

If the impacted apps are greyed out and cannot be pushed to devices, check the Apple Store or the Managed Google Play Store to see if they are still visible.

Workarounds

You may need to contact the developer to get the APK/IPA file if possible.

Was this helpful?