Remote Control Support on Android Enterprise without requiring OEM-specific capabilities or OEM-specific plugin

Publish Date: 15-Oct-2021 Android
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Summary

Issue 

  • Android Enterprise Work Managed Devices (AE-WMD) without a compatible OEM specific Plugin or OEM specific capability, do not have Remote Control (RC) supportIssue 
    • Android Enterprise Work Managed Devices (AE-WMD) without a compatible OEM specific Plugin or OEM specific capability, do not have Remote Control (RC) support 
    • Samsung non-Knox device models enrolled as an AE-WMD with the Enterprise License Management (ELM) License activated have lost RC support after being upgraded to Android 11 

    Cause 

    RC is not a native Google feature for AE-WMD but with OEM specific capabilities (such as the Samsung ELM activation) or OEM specific Plugins, the Android Enterprise agent is able to leverage special privileges and capabilities on that OEM specific device to provide RC support. However, not all OEMs provide specific capabilities or Plugins for RC Support. And in the context of Samsung non-Knox devices, the Samsung Knox APIs enabled by the ELM License activation is no longer supported on Android 11 and above; please navigate to this Central article for more context: https://discussions.soti.net/kb/samsung-elm-not-supported-on-select-android-11-non-knox-samsung-devices. 

    Resolution 

    To be able to remotely control AE-WMD devices without requiring an OEM specific capability or an OEM specific Plugin, please send the following script command to the device: 

    • enforce_rcaccessibility 1 

    Once the script is sent to the device, the Android agent will restart and then a pending action comes to the foreground. The device user will then have to resolve that mandatory pending action on the Android agent. Clicking on that pending action will take the device user to the Device Settings page to enable “Accessibility” for the MobiControl Android agent. Upon enablement, the agent will have RC support without requiring OEM-specific capabilities or OEM-specific plugin.   

    Known Limitations 

    • Device User must accept the “Recording or Casting with MobiControl” prompt for each RC session to begin
    • Issues with ‘Swipe to unlock’ for Android devices on OS11 
    • User cannot type on device using PC keyboard via Remote Control  
    • In Device Details card on the agent, Supported APIs field will display "Virtual Display (RC+)." The MobiControl Web Console will display this in Device Info for such devices in a future release. 
    • Unable to take remote control of some Honeywell & Zebra devices when RC enforce script is sent. As a workaround, restarting the device will resolve this issue. 
    • If for any reason MobiControl Android agent crashes, then the device user will have to resolve the pending action again. 

    FAQs 

    What OEMs are supported? 

    All OEMs are supported including Samsung non-Knox devices. 

    What version of the Android OS is supported? 

    All devices on Android 7 and above that have Accessibility Services are supported. 

    What type of Android management is supported? 

    Only devices enrolled as Android Enterprise Work Managed are supported.  

    What version of the Android agent version is supported? 

    Only devices enrolled with an Android Enterprise agent version 15.0.1 or above. 

    Is it mandatory to resolve the pending action on the Android agent? 

    Yes, it is a mandatory pending action that must be resolved. The Accessibility Service must be granted for the Android Enterprise agent so that the agent can have RC support via Accessibility Service.  

    Can the pending action be actioned without requiring User interaction? 

    No, this pending action requires device user interaction. 

    Will the pending action be shown during an agent upgrade?  

    The pending action will only be shown when the script is sent by the MobiControl administrator, and the Accessibility service has not been granted for the Android Enterprise agent. 

    Will the pending action be shown during enrollment? 

    The pending action will only be shown when the script is sent by the MobiControl administrator, and the Accessibility service has not been granted for the Android Enterprise agent. 

    How should I revert the enforcement of RC via Accessibility Services? 

    You can revert the enforcement of RC via Accessibility Services by sending the following script command to the device: 

    • enforce_rcaccessibility 0 

    Note, sending this script will restart the Android agent.

    What happens if I send this script to devices which have a policy like Lockdown that restricts access to the Device Settings? 

    You will have to provide access to Device Settings for the device user to resolve the mandatory pending action. 

    Should I send this script when the device already has RC support?  

    If your device already has RC support via an OEM specific capability or an OEM specific Plugin, then you do not need to send this script command.  

    What happens if I send this script command when the device already has RC support? 

    The Android Enterprise agent will ensure that RC functions only via Accessibility APIs over any other RC capable APIs that may be available on the device via OEM specific capability or OEM specific Plugin.  

    Are there any limitations to RC via Accessibility APIs? 

    Please see notes under “Known Limitations” above. 

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