Select Samsung device models lose management capabilities after being upgrade to Android 11
Summary
Issue
Samsung device models enrolled as Android Classic or as Android Enterprise with ELM activation have lost some or all management capabilities after being upgraded to Android 11. Consequently, these devices may experience the following issues:
- They can no longer be enrolled as Android Classic devices.
- They can no longer be remote controlled.
- Device configurations can no longer be applied/removed.
Related SOTI ONE Platform Products
Process Description
Issue
Samsung device models enrolled as Android Classic or as Android Enterprise with ELM activation have lost some or all management capabilities after being upgraded to Android 11. Consequently, these devices may experience the following issues:
- They can no longer be enrolled as Android Classic devices.
- They can no longer be remote controlled.
- Device configurations can no longer be applied/removed.
Cause
Many features on Samsung devices today are powered by leveraging Samsung KNOX APIs. As of Android 11, select Samsung device models no longer support these ELM/KNOX APIs. This means that any feature, including Remote Control, which uses ELM/KNOX APIs will no longer be configurable or achievable in Android OS 11 for these devices.
You can find the up-to-date list of devices that do not support ELM/KNOX API activation (as of Android 11):
- Navigate to https://www.samsungknox.com/en/knox-platform/supported-devices
- Use the filter on the left side of the website select: "Android - Others" and "Android Go" under the PLATFORM/OS section.
As of the time of writing this article that is 29 out of 340 models.
Note: not all devices on that list will receive and support Android 11 OS Updates.
Resolution
Option 1: Re-enroll as Android Enterprise Devices
Enroll new devices as Android Enterprise devices.
For current enrolled devices, factory reset the devices and enroll them as Android Enterprise.
Known limitation: Presently, with unavailability of KNOX/ELM on these models, you will not able to use Remote Control. The only option available will be remote view.
Option 2: Disable OS Updates and Enable Factory Reset through Feature Control for Android Classic
Create a profile with a Feature Control Payload for your affected devices that allows 'Factory Reset' and does not allow 'OS Updates' on the device. This ensures that your devices does NOT upgrade to Android 11 and lose aforementioned functionality and enables you to factory reset the device in the event where you would like to re-enroll it as Android Enterprise (see option 1)

Option 3: You can also view the following SOTI Central Article to Block OS upgrades on Samsung Work Managed devices
FAQs
What is the impact on Android Enterprise management?
Samsung Android 11 device models that are not secured by Knox will retain the ability to enroll into SOTI MobiControl as an Android Enterprise device since this management relies on Google’s native framework. However, on the non-Knox devices for Android Enterprise, the Samsung ELM License cannot be activated and so, the device cannot be remotely controlled, nor can several other configurations that rely on Samsung ELM be applied.
What happens to enrolled Android Enterprise devices that upgrade to Android 11?
Upon upgrade to Android 11 on Samsung device models that are not secured by Knox and were already enrolled and managed as an Android Enterprise Work Managed device with an activated Samsung ELM License, can no longer be remotely controlled. Additionally, any configuration that relies on Samsung ELM cannot be applied, nor can they be revoked if they were applied prior to the upgrade. All other Android Enterprise configurations that rely on Google’s native framework will continue to work.
What is the impact on Android Classic management?
Samsung Android 11 devices models that are not secured by Knox will not be able to enroll into SOTI MobiControl as an Android Classic device with a Samsung ELM agent.
What happens to enrolled Android Classic devices that upgrade to Android 11?
Upon upgrade to Android 11 on Samsung device models that are not secured by Knox and are already enrolled and managed as an Android Classic device, the device will no longer be manageable; new device configurations cannot be applied post upgrade and configurations applied prior to upgrade cannot be revoked. Additionally, the device cannot be remotely controlled.
How can I learn if my managed devices are affected?
Please click here to learn which Samsung devices are secured by Knox. Any device that falls under “Android – Others” or “Android Go” are devices that are not secured by Knox.
How can I prevent my device from upgrading to Android 11?
Please review the SOTI Central article that contains a script that blocks operating system upgrades which can be sent to Samsung devices that can detect KNOX capability. The script can be sent to a device enrolled as an Android Enterprise Work Managed Device with an activated Samsung ELM License or an Android Classic device enrolled with a Samsung ELM agent.
What are my options for resolution if the device has already been upgraded to Android 11?
Please see section “Resolution” above.
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