Agent installation issues during SOTI MobiControl upgrade

Publish Date: 16-May-2025 Last Modified Date: 17-Sep-2025 SOTI MobiControl
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Summary

This article outlines workarounds to address agent installation errors and issues that may occur following an upgrade.

Related SOTI ONE Platform Products

SOTI MobiControl

Related Device OS

Windows Modern

Issue Description

During the upgrade of the Windows Modern agent to version 2025.x.x, the new agent installation may fail due to one of the following reasons:

  • An existing agent service is still running on the device.
  • The agent MSI was not successfully delivered to the device during the upgrade process.

Environment

This issue is observed during upgrades from any MobiControl (MC) version to 2025.x.x.

Symptoms

  • Multiple agent installation attempts result in several agent MSI files being created under:
     C:\Windows\System32\config\systemprofile\AppData\Local\mdm
  • The device appears online with an older agent version, but:
    • Remote actions cannot be performed.
    • Device sync consistently fails.

Prevention

  • Before performing a full-scale upgrade, test the upgrade on 1–2 devices.
  • If the upgrade fails on these test devices, apply the workaround on the same set before proceeding further.
  • Collect agent and server logs prior to applying any workaround to help with troubleshooting and root cause analysis.

Cause

  • The older agent service is still running on the device, which prevents the successful installation of the new agent.
  • In some cases, the new agent MSI is not delivered to the device during the upgrade process.

Issue Resolution

Scenario 1

The new agent MSI is not sent to the device even though the device is online.

Resolution Steps:

1. Update Agent Compatibility Table

Inform the system that the current agent version on the device is incompatible to trigger sending the new agent.

Modify the MinCompatibleVersionMajor and MinCompatibleVersionMinor columns in the AgentCompatibility table to either:

  • Match the current agent version on the device, or
  • Set as:

MinCompatibleVersionMajor = 14 

MinCompatibleVersionMinor = 0

Example SQL Queries:

  • If the agent version on the device is 15.6.6.123:
UPDATE AgentCompatibility SET MinCompatibleVersionMajor = '15', MinCompatibleVersionMinor = '66' WHERE DeviceFamily = '8';
  • If the agent version on the device is 2025.0.0.234:
UPDATE AgentCompatibility SET MinCompatibleVersionMajor = '2025', MinCompatibleVersionMinor = '0' WHERE DeviceFamily = '8';

Notes:

  • Always backup the existing database values before making any updates.
  • Restore the original database values once the agent has been successfully upgraded.

2. Send the Agent MSI manually using MC Packages.

Sending the Agent MSI Using a Package with Post-Install Powershell Script

  • Ensure the $msiPath in the package and script are identical.
  • Replace 'qa2016-1234.sotiabc.com' with the customer’s server name.
$registryPath = "HKLM:\SOFTWARE\WOW6432Node\SOTI\MobiControl\PDB\Comm"
$propertyName = "CertId"
$value = (Get-ItemProperty -Path $registryPath -Name $propertyName).$propertyName
$msiPath = "C:\MSI\ModernAgentSetup.msi"
$command = "msiexec /i `"$msiPath`" CONFIGENDPOINT=https://qa2016-1234.sotiabc.com/WindowsApplicationProvider.svc ASSOCIATIONHASH=$value /l*vx `"log.log`""

Invoke-Expression $command
  • Wait for 15 minutes, then reboot the device.
  • After reboot, verify that the agent version in device details is updated.

Scenario 2

The new agent MSI is sent and installed on the device, but the agent service fails to start because the old agent was not completely uninstalled. The device shows as offline.

Resolution Steps:

1. Send the AgentServiceRemoverInstaller MSI to the affected devices. This tool removes the running older agent service that blocks the new agent from starting.

2. Perform an MDM check-in on the device.

3. Wait for approximately 15 minutes (depending on network speed and server performance).

4. The new agent should now install properly and start running automatically.

Workarounds

Side Effects of the Workaround:

  • After applying the workaround, you may observe two instances of the agent listed under Installed Applications on the device.
  • If this occurs, please reach out to the SOTI Support team for further assistance in cleaning up the redundant agent entry.

Additional Information

  • If the agent upgrade still fails, collect device and agent logs for further investigation.
  • Contact the support teams to obtain the correct agent MSI if required.

 

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