Changes in iOS / iPadOS 15 and macOS Monterey that impact SOTI MobiControl Profiles
Summary
Issue
MobiControl customers that run their devices on iOS / iPadOS15 and macOS Monterey will fail to install a profile that contains more than one instance of any of the following configuration payloads:
iOS/iPadOS
-Calendars
-Certificates
-Custom Profiles
-Contacts
-Email
-Extensible Single Sign On
-VPN
-SCEP
-Web Clip
-WiFi-AirPrint
-Fonts
macOS
-Accessibility
-
Related SOTI ONE Platform Products
Process Description
Issue
MobiControl customers that run their devices on iOS / iPadOS15 and macOS Monterey will fail to install a profile that contains more than one instance of any of the following configuration payloads:
iOS/iPadOS
-Calendars
-Certificates
-Custom Profiles
-Contacts
-Email
-Extensible Single Sign On
-VPN
-SCEP
-Web Clip
-WiFi-AirPrint
-Fonts
macOS
-Accessibility
-Desktop Wallpaper & Screen Saver
-Dock
-Email
-Energy Saver
-Ethernet
-Extensions
-Firewall
-FileVault
-Software Update
-Security & Privacy
-VPN
-WiFi
-AirPrint
-Fonts
-LDAP
-Login Window
-Directory
-Feature Control
-Login Items
-Time Machine
Cause
iOS / iPadOS 15 and macOS Monterey include changes that affect customers that have at least one configuration profile with multiple instances of the same iOS or macOS configuration payload within that profile. Until affected customers take one of the actions outlined below, affected devices will fail to install a profile that contains more than one instance of any of the configuration payloads listed above.
Resolution
SOTI will issue maintenance releases for SOTI MobiControl v14 and v15 in order to support the new configuration profile requirements introduced in iOS15, iPadOS 15, and macOS Monterey.
Recommended course of action for affected customers
- Customers running SOTI MobiControl 14.5.7 or lower should upgrade to 14.5.8 (to be released November 15, 2021) or higher.
- Customers running SOTI MobiControl 15.4.1 or lower should upgrade to 15.4.2 (to be released December 20, 2021) or higher.
Workaround for affected customers
Affected customers who need an immediate resolution may split their profiles so that each profile contains at most one of each of the configuration payloads mentioned above. For example, an existing profile containing 2 Web Clip payloads would be split into profile 1 containing the first Web Clip payload and profile 2 containing the second Web Clip payload.
If you have any questions about this, please contact SOTI Support for assistance.
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