Failure to Add or Refresh a VPP Token with a Custom (B2B) App
Summary
Issue
This issue surfaces when attempting the following scenarios in the "Apple Volume Purchase Program" (VPP) dialog of "Global Settings":
- When attempting to add a VPP Token that contains licenses for Custom (also known as B2B) apps, SOTI MobiControl prompts the user with a message stating, "MobiControl could not establish connection with Apple services at the moment. Please try again later."
- When attempting to refresh an exi
Related SOTI ONE Platform Products
Process Description
Issue
This issue surfaces when attempting the following scenarios in the "Apple Volume Purchase Program" (VPP) dialog of "Global Settings":
- When attempting to add a VPP Token that contains licenses for Custom (also known as B2B) apps, SOTI MobiControl prompts the user with a message stating, "MobiControl could not establish connection with Apple services at the moment. Please try again later."
- When attempting to refresh an existing VPP Token that contains licenses for Custom (also known as B2B) apps, SOTI MobiControl prompts the user with a message stating, "The server could not complete your request. An internal error occurred."
Affects
This issue affects the following versions of SOTI MobiControl:
- v14.5.1 and lower
- v15.1.2 and lower
Cause
SOTI MobiControl leverages Apple's iTunes Service to retrieve information about Custom apps. On or around July 15, 2020, Apple made a change to the response of the iTunes Service when requesting information about Custom apps. This change is incompatible with the aforementioned versions of SOTI MobiControl.
Resolution
This issue can be resolved by upgrading SOTI MobiControl to either:
- v14.5.2 or higher
- v15.2.0 or higher
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